Ответ
 
Опции темы
Старый 23.08.2023, 08:05    | »»» |  #1
ngbr
Начинающий
 
Аватар для ngbr
 
Белгород, Белгородская обл, Негабаритика
Регистрация: 29.07.2021
Сообщений: 10
ngbr is on a distinguished road
По умолчанию СОМ-сервер АвтоГРАФ

Получить данные.
ngbr вне форума   Ответить с цитированием
Старый 23.08.2023, 08:45    | »»» |  #2
ngbr
Начинающий
 
Аватар для ngbr
 
Белгород, Белгородская обл, Негабаритика
Регистрация: 29.07.2021
Сообщений: 10
ngbr is on a distinguished road
По умолчанию

Код:
AG.StartComputing  ("",НомерУстройства,НачПериода,КонПериода,"GSM",0); 
      AG.WaitForComputing("",НомерУстройства,НачПериода,КонПериода,"GSM",0);
AG.TripEntriesListTypeName="over_speed"
Данные получаю по параметрам из настроек объекта мониторинга Максимальный порог ,км.ч 70
Игнорировать превышения 180
Могу ли я передать отличные от настроек в дизайнере параметров параметры в расчет и получить результат?

Последний раз редактировалось Phantom; 26.08.2023 в 06:15.
ngbr вне форума   Ответить с цитированием
Старый 24.08.2023, 09:43    | »»» |  #3
ngbr
Начинающий
 
Аватар для ngbr
 
Белгород, Белгородская обл, Негабаритика
Регистрация: 29.07.2021
Сообщений: 10
ngbr is on a distinguished road
По умолчанию СОМ-сервер АвтоГРАФ

Добрый день.
Нажмите для просмотра содержимого...
Код:
Процедура НарушениеСкоростногоРежима(НомерУстройства,ДатаНачало,ДатаОкончание,ПорогПревышения,ПорогПродолжительности,МассивУчастков)
	 НачПериода = Формат(ДатаНачало,   "ДЛФ=ДВ");
	 КонПериода = Формат(ДатаОкончание,"ДЛФ=ДВ");
	 AG = Новый COMОбъект("AutoGRAPH.AutoGRAPHAutomation");   
	 ddd  = AG.WaitForInitializing();
	 AG.WaitForComputing("",НомерУстройства,НачПериода,КонПериода,"GSM",0);
	 КолРейсов = AG.TripsNum;
	  МассивУчастков = Новый Массив;	 
		 Для ИндексРейса = 1 По КолРейсов Цикл 
			 AG.TripIndex = ИндексРейса;
			 AG.TripEntriesListTypeName="over_speed";
			     Для ИндексЗаписи = 1 По AG.TripEntriesNum Цикл 
					 AG.EntryIndex = ИндексЗаписи;
					 Если НетСигнала(НомерУстройства,AG.EntryStartRealTime,AG.EntryEndRealTime) Тогда
					    Продолжить; 
					 КонецЕсли;
					 ////////
					 ////////
					 ////////
					 ////////
					 ////////  Обрабатываю результат отчета
					 ////////
					 ////////
					 ////////
					 ////////
				 КонецЦикла;
		КонецЦикла;
КонецПроцедуры

Результат получаю по значениям параметров в дизайнере параметров объекта мониторинга
- Максимальный порог и игнорировать превышения с продолжительностью менее,с
ВОПРОС: Можно ли передать в расчет свои параметры порога скорости и и длительности нарушения отличные от установленных в дизайнере параметров?
АвтоГРАФ.Pro 7.2

Последний раз редактировалось Phantom; 25.08.2023 в 05:22.
ngbr вне форума   Ответить с цитированием
Старый 25.08.2023, 05:28    | »»» |  #4
Phantom
ТехноКом
 
Аватар для Phantom
 
Челябинск, ООО НПО "ТехноКом"
Регистрация: 28.05.2010
Сообщений: 2,141
Phantom has much to be proud ofPhantom has much to be proud ofPhantom has much to be proud ofPhantom has much to be proud ofPhantom has much to be proud ofPhantom has much to be proud ofPhantom has much to be proud ofPhantom has much to be proud of
По умолчанию

ngbr, для Вас в редакторе форума предусмотрены коды. Пользуйтесь.

ООО НПО «ТехноКом», г. Челябинск
Попов Дмитрий Александрович, старший инженер по ремонту оборудования
Phantom на форуме   Ответить с цитированием
Старый 28.08.2023, 10:28    | »»» |  #5
SK
Администратор
 
Аватар для SK
 
Регистрация: 27.05.2010
Сообщений: 29,977
SK has much to be proud ofSK has much to be proud ofSK has much to be proud ofSK has much to be proud ofSK has much to be proud ofSK has much to be proud ofSK has much to be proud ofSK has much to be proud of
Отправить сообщение для SK с помощью Skype™
По умолчанию

Сообщение от ngbr Посмотреть сообщение
ВОПРОС: Можно ли передать в расчет свои параметры порога скорости и и длительности нарушения отличные от установленных в дизайнере параметров?
Нет. Расчет с произвольными параметрами, задаваемыми при вызове расчета, не предусмотрен и даже вреден в плане получения сфальсифицированных данных и утаивания реальных нарушений.

ООО «ТехноКом», г. Челябинск
Самцов Константин Юрьевич - зам. директора по коммерческой деятельности
SK вне форума   Ответить с цитированием
Старый 25.10.2023, 12:15    | »»» |  #6
NickolaDed
Дилер
 
Аватар для NickolaDed
 
ООО "Системы Контроля и Анализа Транспорта", г. Нижний Новгород
Регистрация: 17.05.2011
Сообщений: 5,672
NickolaDed is on a distinguished road
Отправить сообщение для NickolaDed с помощью ICQ Отправить сообщение для NickolaDed с помощью Skype™
По умолчанию

Сообщение от ngbr Посмотреть сообщение
Добрый день.
Нажмите для просмотра содержимого...
Код:
Процедура НарушениеСкоростногоРежима(НомерУстройства,ДатаНачало,ДатаОкончание,ПорогПревышения,ПорогПродолжительности,МассивУчастков)
	 НачПериода = Формат(ДатаНачало,   "ДЛФ=ДВ");
	 КонПериода = Формат(ДатаОкончание,"ДЛФ=ДВ");
	 AG = Новый COMОбъект("AutoGRAPH.AutoGRAPHAutomation");   
	 ddd  = AG.WaitForInitializing();
	 AG.WaitForComputing("",НомерУстройства,НачПериода,КонПериода,"GSM",0);
	 КолРейсов = AG.TripsNum;
	  МассивУчастков = Новый Массив;	 
		 Для ИндексРейса = 1 По КолРейсов Цикл 
			 AG.TripIndex = ИндексРейса;
			 AG.TripEntriesListTypeName="over_speed";
			     Для ИндексЗаписи = 1 По AG.TripEntriesNum Цикл 
					 AG.EntryIndex = ИндексЗаписи;
					 Если НетСигнала(НомерУстройства,AG.EntryStartRealTime,AG.EntryEndRealTime) Тогда
					    Продолжить; 
					 КонецЕсли;
					 ////////
					 ////////
					 ////////
					 ////////
					 ////////  Обрабатываю результат отчета
					 ////////
					 ////////
					 ////////
					 ////////
				 КонецЦикла;
		КонецЦикла;
КонецПроцедуры

Результат получаю по значениям параметров в дизайнере параметров объекта мониторинга
- Максимальный порог и игнорировать превышения с продолжительностью менее,с
ВОПРОС: Можно ли передать в расчет свои параметры порога скорости и и длительности нарушения отличные от установленных в дизайнере параметров?
АвтоГРАФ.Pro 7.2
А зачем вы балуетесь COM сервером? Не проще работать с АПИ Веб Сервера?
__________________
ООО «Системы Контроля и Анализа Транспорта»
Бородин Николай Олегович, ген. директор
Тел.: +7 (831) 42-42-3-42, E-mail: info@ckat-nn.ru
Тел.: +7 (904) 397-90-81, skype: nickola8787, E-mail: nborodin@ckat-nn.ru
http://скат-нн.рф
http://cloud.ckat-nn.ru

ООО "Системы Контроля и Анализа Транспорта" г. Нижний Новгород
Бородин Николай Олегович, ген. Директор
NickolaDed на форуме   Ответить с цитированием
Старый 13.11.2023, 02:28    | »»» |  #7
MartynenkoES
Дилер
 
Аватар для MartynenkoES
 
Иркутск, "Эсмиком и К"
Регистрация: 20.03.2017
Сообщений: 342
MartynenkoES is on a distinguished road
По умолчанию

Сообщение от ngbr Посмотреть сообщение
Добрый день.

ВОПРОС: Можно ли передать в расчет свои параметры порога скорости и и длительности нарушения отличные от установленных в дизайнере параметров?
АвтоГРАФ.Pro 7.2
1. Перестаете использовать COM, переходите на Web API
2. Параметризуете через реестр свойств расчёт нужных параметров
3. Пишете в реестр свойств нужные значения свойств перед запросом расчёта.
4. Запрашиваете.
5. Получаете нужный результат.

ООО "Эсмиком и К", г. Иркутск, Иркутская область, Россия
Мартыненко Евгений Сергеевич, главный инженер
MartynenkoES вне форума   Ответить с цитированием
Старый 13.11.2023, 11:15    | »»» |  #8
plex
Дилер
 
Аватар для plex
 
Екатеринбург, ЗАО "Седьмая Экспедиция"
Регистрация: 14.12.2010
Сообщений: 14,959
plex is on a distinguished road
Отправить сообщение для plex с помощью ICQ Отправить сообщение для plex с помощью Skype™
По умолчанию

Сообщение от MartynenkoES Посмотреть сообщение
1. Перестаете использовать COM, переходите на Web API
не всегда это так легко и просто, может быть легко интегрировано в структуру предприятия, где выхода на внешний веб нет, а свой стваить то еще удовольствие

ЗАО "Седьмая Экспедиция", Екатеринбург, РФ
Мушин Виктор Валерьевич, Технический директор
plex вне форума   Ответить с цитированием
Старый 08.04.2024, 06:42    | »»» |  #9
Федоров Павел
Начинающий
 
Аватар для Федоров Павел
 
.
Регистрация: 08.04.2024
Сообщений: 3
Федоров Павел is on a distinguished road
Thumbs up COM-сервер Автограф 4

Добрый день.
Помогите, пожалуйста!
Не могу разобраться как из СОМ-клиента в приложении Автограф 4 открыть нужный вид отрезка данных?
Открываю приложение и нужное ТС за период времени, например следующим образом:
Set AutoGRAPH = CreateObject("AutoGRAPH.AutoGRAPHAutomation")
If InStr(AutoGRAPH.CurrentVersion, "4.0") > 0 Then
AutoGRAPH.ReceiveOnlineData Блок 'обновляем данные по ТС с сервера
AutoGRAPH.StartComputing "*", Блок, ДатаИзИмениФайла, ДатаИзДанных, "GSM", 0
AutoGRAPH.ShowApplication
End If
Федоров Павел вне форума   Ответить с цитированием
Старый 09.04.2024, 16:51    | »»» |  #10
SK
Администратор
 
Аватар для SK
 
Регистрация: 27.05.2010
Сообщений: 29,977
SK has much to be proud ofSK has much to be proud ofSK has much to be proud ofSK has much to be proud ofSK has much to be proud ofSK has much to be proud ofSK has much to be proud ofSK has much to be proud of
Отправить сообщение для SK с помощью Skype™
По умолчанию

Что значит "нужный вид"???
COM-сервер не предназначен для управления интерфейсом ПО.
Некоторые побочные эффекты в интерфейсе при расчете через COM обусловлены устаревшей архитектурой, от которой избавились в версии 5 и выше.
Почти 10 лет прошло с выхода последней сборки АвтоГРАФ 4.х...

ООО «ТехноКом», г. Челябинск
Самцов Константин Юрьевич - зам. директора по коммерческой деятельности
SK вне форума   Ответить с цитированием
Ответ


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Текущее время: 10:50. Часовой пояс GMT.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd. Перевод: zCarot